1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. REMINDER

    Any content, information, or advice found on social media platforms and the wider Internet, including forums such as AP, should NOT be acted upon unless checked against a reliable, authoritative source, and re-checked, particularly where personal health is at stake. Seek professional advice/confirmation before acting on such at all times.

W/O lens

Discussion in 'Panasonic Chat' started by sappymike12, Dec 1, 2019.

  1. sappymike12

    sappymike12 Well-Known Member

    Hi I wonder if anybody can answer this for me. I fitted one of my telephoto lens to my camera a 45 - 150 to take shots at my local Marina and found I could not get a pin sharp focus, I have not had this problem before, so I load the images on the computer to see all of them, and yes all out of focus,next I put the smaller lens on and tested it and had the same result so I put a M/F lens on and set the camera to work without a lens.

    It worked I got pin sharp focus and the images loaded pin sharp so next put original lens back on and check great sharp focus,next the telephoto lens and again sharp focus.

    My question is why does it work on the W/O lens and not with the lens ?

    The camera is a G3.

    Many thanks

    Mike
     
  2. PeteRob

    PeteRob Well-Known Member

    You'll have to check the user manual to say what it says for your camera. Most cameras these days are linked electronically with the lens and by default they only work (shutter fire etc.) when a lens they recognise is attached. I guess this is a safety feature to prevent damage due to fingers in the wrong place if the camera is turned on with the lens demounted. When mirrorless cameras were first introduced the potential to use other brand or old lenses by means of adaptors was met with some enthusiasm, especially as there were not that many system lenses. For the cameras to work with these old or otherwise incompatible lenses it was necessary to disable the dependence of the camera on the lens. So most cameras (mirrorless and DSLR) have a setting to disable the lens dependence (without lens) which means the camera will work whether or not it has a lens that it recognises attached.

    If you were getting auto focus issues with your zoom there are a number of possibilities. i) it wasn't fully attached or there is some dirt on the contacts ii) AF was disabled iii) image stabilisation was disabled - we get so used to it that it is easy to take it for granted iv) someone has been playing with the focus micro-adjust v) focus using the shutter release has been disabled (back button focus mode). The last one is quite common if someone is messing in the menus and doesn't realise what it does.
     
    Mark101 likes this.
  3. sappymike12

    sappymike12 Well-Known Member

    Thanks Pete I have done some head scratching and not getting very far, so have done a reset and it look like we are back to normal ? Why it went like that I do not know but have fingers crossed for now.

    Mike
     
  4. PeteRob

    PeteRob Well-Known Member

    Probably a bit of dirt. Gently clean the contacts if it happens again.
     
  5. SXH

    SXH Well-Known Member

    You didn't accidentally hit the iA button did you? That can cause strange things to happen. I got caught that way with my G6.
     
  6. sappymike12

    sappymike12 Well-Known Member

    Who knows Steve, may be.
     
  7. El_Sid

    El_Sid Well-Known Member

    Was the focus point actually in the right place? I know this sounds silly but I had focusing problems with my G3 recently, it either wouldn't focus at all or was out of focus and I couldn't immediately work out why. After a bit of fiddling about I realised the focus point had ended up in the bottom left corner hidden behind the histogram display. As soon as I set it back to the middle focusing went back to normal...
     
  8. sappymike12

    sappymike12 Well-Known Member

    No the focus point is spot on but just that bit out of focus. I will find it, but for now Ok

    Thanks
    Mike
     

Share This Page