1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S120 battery life

Discussion in 'Canon Conflab' started by bench_ubbster, Jul 2, 2014.

  1. bench_ubbster

    bench_ubbster Well-Known Member

    I did a quick look to see if people are having issues with battery life particularly with the S120. I have several spare batteries but all seem to discharge very quickly with this camera particularly if taking video. It doesn't seem to be a problem with the battery per se (as the batteries are fine in my wife's SX260). Normal photo usage isn't too bad (I've known better) but with video I can only get 15-20s on a fully charged battery before it displays the red empty battery sign on screen. I've decreased the screen brightness and not used zoom (or GPS or wi-fi) but it still discharges quickly. Turning the camera off, taking the battery out and putting in again displays the battery has some charge, but then when filming, the same happens again. Just wondered if anybody else had experienced this or I should get it seen to? Apart from that, I'm liking everything else about this camera.
     
  2. PeteRob

    PeteRob Well-Known Member

    It does not sound right. Does the manual not have indicative timings?
     
  3. bench_ubbster

    bench_ubbster Well-Known Member

    It only says approx 30 mins.

    Approx. 230 shots
    Eco mode approx. 300 shots
    Approx. 240 min. playback

    Yes, I would say I'm getting about 230 shots, but just using the video with freshly charged battery I get about 30 seconds.
     
  4. bench_ubbster

    bench_ubbster Well-Known Member

  5. bench_ubbster

    bench_ubbster Well-Known Member

    I'll try putting a bit of tape over the middle contact of the battery to see if that makes a difference.
     
  6. bench_ubbster

    bench_ubbster Well-Known Member

    A fine piece of Sellotape over the middle contact of the battery seems to work a treat. So far, I've videoed over 3 mins and the battery is still good. :)

    Now the question is, do I removed the Sellotape when I charge the battery?
     
  7. Snorri

    Snorri Well-Known Member

    I know what you meen, my S100 takes pictures for ever but put on video and the red battery symbol starts to blink...
     
  8. Kate17

    Kate17 New Member

    Can you share with us the photo of how to do it? How about when we charge it, do we need to take the tape off?

    Thank you in advance for your answer.
     

Share This Page