1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems using the Acer Scanwit 2720s

Discussion in 'Digital Image Editing & Printing' started by mr_zuiko, Apr 9, 2010.

  1. mr_zuiko

    mr_zuiko Member

    Hi this is my first post here and i'm hoping that you can help me with my Acer 2720s film scanner I recently bought the ScanWit2720s scanner ,but i am having a few teething problems let me explain.
    I am running Windows XP after i was assured by the seller that it was
    compatible with this OS,the scanner is connected by the SCSI in connection with
    the ID set to 2 as i have no other piece of equipment connected via SCSI card.
    The card is a ACARD AEC-6710D which was sent with the scanner,i'm using
    photoshop CS4.
    Having installed the card,then the latest driver to include windows XP,i
    aquire through the import selection in photoshop,it finds the scanner,i insert
    the film strip etc but all i get is "black" frames where the thumbnails should
    be with this message-
    "Read image data failure
    "Please check if the LED indicator stays on (ready mode) which it does but i
    get this code [ffff:0025]" Also i have had this come up too,
    Auto focus code [ffff:0066] do you think thaty there is something major wrong with this scanner and should return it or i'm doing something wrong?
    I really want to use this scanner as i have just got myself another Nikon F3 which i love.
    Any advice or help would be very helpful.
     
  2. SqueamishOssifrage

    SqueamishOssifrage Well-Known Member

    Do you have a SCSI terminator fitted on the second SCSI port on the scanner?
     
  3. RogerB

    RogerB Well-Known Member

    It may be worth trying Vuescan (just Google it) as the capture environment rather than Photoshop. This would take some of the variables out of your situation. Vuescan gives you more control over the scanner and it does support the ScanWit 2720S.

    Roger
     
  4. mr_zuiko

    mr_zuiko Member

    Hi thanks for your reply....SCSI terminator no i havn't got one fitted,i have read about them on the net,am i right in thinking that it should be of the "passive" kind.
    You say put it on the second SCSI port do you mean the "out" port where i have the cable connected already?


    Regards Ash.
     
  5. mr_zuiko

    mr_zuiko Member

    Hi Roger,
    Yes i did try Vuescan but that didn't help either,but i will give it another go when i have bought a SCSI terminator to see if that has any effect i hope so as i have seen very good reviews of this scanner and i can't wait to start developing my b&w neg's again.
    Thanks for all the help here and i will keep you posted.

    Regards Ash.
     
  6. sillyconguru

    sillyconguru Well-Known Member

    I use a Scanwit 2720S scanner with a Acard AEC-6710D SCSI card (with no SCSI terminator) on a XP machine with Service Pack 1, with no problems whatsoever. The driver pack for the SCSI card (AFAIK) was downloaded as the Zip file AEC671X_VER233, this might not be correct though. I can't remember off-hand what version of Miraphoto is used but it also works fine with Vuescan.

    What Service Pack is installed on your PC? I'm not sure if Service Pack 2 (or 3) would cause problems but I did read a few scare-stories when it was released about older devices not working after upgrading to SP2; this is why I haven't bothered.
     
  7. mr_zuiko

    mr_zuiko Member

    Hi Ummm....i have service pack 3 installed at present to be honest i wouldn't have even thought of that!
    This might be a dumb question but would i be able to go back to service pack 1 and give it a try and if so how would i do it?

    Regards Ash.
     
  8. sillyconguru

    sillyconguru Well-Known Member

    That was a worry for me as I had read that rolling back from SP2 to SP1 still didn't allow the older software (not necessarily anything to do with Acer/Acard drivers) to work again; hence I haven't tried it.

    If you didn't upgrade from SP1 to SP3 then you would most likely have to uninstall SP3 then install SP1. This is assuming that your version of XP didn't have any service packs pre-installed; I don't know what you'd do if it was a OEM version with SP2 installed already.

    Don't take my experience (or lack of it) as Gospel. All I've done is not install SP2 or SP3; my machine works OK with SP1 so I didn't chance it.
     
  9. SqueamishOssifrage

    SqueamishOssifrage Well-Known Member

    Sorry for the late reply - you answered someone else so I didn't get to see your question.
    The scanner has two ports on it - one for the connection to the PC, and the other for daisy-chaining to another SCSI device. If you have no other SCSI device(s) to connect, then you should use a SCSI passive terminator in the correct physical format (25 pin "D" type socket in your case) for the scanner, on the second port on the scanner. Convention has the SCSI card set as ID 0, and other devices from 1 to 7 (or 1 to 15, but not in your case). Also, the 'In' and 'Out' ports on the scanner refer to the card or controller, so the PC card should be connected to the 'In' port, and the terminator to the 'Out' port.
     
  10. mr_zuiko

    mr_zuiko Member

    Hi
    Thanks for your help,i have just ordered the SCSI passive terminator and will try again when it arrives and hopefully get the scanner working!

    Thanks again i'll keep everyone posted.

    Ash.
     
  11. Derrickg

    Derrickg New Member

    Hi
    I am trying to transfer my scanwit 2720s onto an xp computer but the scsi card has a female socket and the input to the scanwit is also a female socket but there do not seem to be any male to male connectors. I must be doing something wrong but it is too long ago that I used it before and I can't remember the set up. Grateful for advice.
     
  12. palough

    palough New Member

    Hi, I've owned a Scanwit 2740S for many years and used it to write several photographic books, the last being published in 2007.

    I also have a Nikon IVED scanner but the Scanwit produces better results and much quicker being able to batch scan.

    I have been asked to write a new photographic book, so pulled the scanner out of its original box and have connected it to the notebook computer via a Microtech SCSI-USB cable.

    the scanner works fine with VueScan and I can start MiraFoto, but during scanning I get a "read image data failure. Please check if the LED indicator stays on (ready mode)".

    the LED indicator stays on and all appears OK with the scanner.

    I have read somewhere that I might need a passive SCSI terminator on the output.

    I would like to know if a passive SCSI terminator solved your problem?

    I know its many years since your posting but hopefully you are still liked to this site.

    Cheers,

    Peter
     
    Last edited: Feb 2, 2016
  13. SXH

    SXH Well-Known Member

    IIRC all SCSI chains need a terminator at the end, i.e. in the empty socket of the last device in the chain.

    A bit like the old thin-wire ethernet.
     
  14. palough

    palough New Member


    Hi,

    thanks for the comment.

    I have ordered a SCSI terminator, lets see how it goes.

    the symptoms look like it could be that problem as it does scan one negative OK, then comes back with data transmission error.

    sometimes when I select one negative at a time it will scan 2 or 3, each time giving the data error but nevertheless, producing a scan.

    if I use the lowest resolution, fast scan and no ICE it seems to be relatively happy, but once the going gets a bit tough it throws in the towel.

    again, thanks for the comment.

    Cheers,
     
  15. palough

    palough New Member

    Scanwit 2470S SCSI Terminator Anomaly?

    Hi,

    I see the comment about having to terminate the other SCSI end, but what is strange is that VueScan works perfectly fine and will batch scan without a SCSI terminator using the Microtech SCSI to USB cable coupled from the scanner computer IN port while the OUT port is open.

    this problem seems limited to the MiraFoto software

    maybe its something to do with the way the software is written.

    anyway, ordered a SCSI terminator as a last resort as the few scans I've managed out of the Scanwit with MiriFoto are better than the VueScan Professional software I purchased, but at least it works and can batch scan quickly.

    Cheers,
     
  16. palough

    palough New Member

    Hi Everyone,

    has anyone had any experience / success at connecting a Acer (Benq) Scanwit Film Scanner with Linux (any distro)?

    Ubuntu 14.04/15.10, Mint and RoboLinux don't find the Film Scanner

    however, Zorin 10 Ultimate does find the Acer Filmscanner and lists it as;

    Color Filmscanner__2 0120 at /dev/sg3

    the Terminal command, sane-find-scanner returns;

    found usb scanner vendor (vendor=0x138a) (product=0x0018) @ libusb:003:003

    running Simple Scan returns and error as follows;

    change scanner, opening the menu dialogue box to change scanner shows it has found the scanner and lists it as;

    Acer FilmScanner__2

    but won't scan.

    I've scoured the Linux Sane "How To's" and various forums but all without success.

    would be great if anyone can assist.

    Cheers
     

Share This Page