1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. REMINDER

    Any content, information, or advice found on social media platforms and the wider Internet, including forums such as AP, should NOT be acted upon unless checked against a reliable, authoritative source, and re-checked, particularly where personal health is at stake. Seek professional advice/confirmation before acting on such at all times.

Photoshop 2020

Discussion in 'Digital Image Editing & Printing' started by dream_police, Apr 17, 2020.

  1. dream_police

    dream_police Well-Known Member

    Anyone help with this please?

    Up until my wife decided she wanted to use PS I would open an image in PS. The right hand pane would show "background" and it would be locked. I could either click to unlock, work on that or duplicate the layer leaving the background still locked.

    Now that she has presumably fiddled with something, the background is locked when first opened but as soon as you do something on that locked background layer, such as just crop, it automatically unlocks, and remains unlocked unless I manually lock it again. Either way the background has by default unlocked which has never been the case. If all I am doing is a crop for instance, nothing more, I still, therefore with it being unlocked, need to go to layers to flatten the image before saving as a JPG. Before, as it remained locked, the option to flatten image was greyed out as it didn't need flattening as I hadn't created a new layer.

    I hope that makes sense.

    How do I change that back to what it should be so that the background remains locked? I know I should be able to reset all preferences to original state but as yet I don't want to do that.


    In pictures.

    Image opens as normal with background layer locked.

    [​IMG]Screenshot 2020-04-17 at 12.05.31 by Nigel G, on Flickr

    Without creating a new layer, all I want to do is crop. Following crop background unlocks and changes its name to Layer 0

    [​IMG]Screenshot 2020-04-17 at 12.06.08 by Nigel G, on Flickr

    I can create new layers but the background (layer 0) remains unlocked

    [​IMG]Screenshot 2020-04-17 at 12.07.14 by Nigel G, on Flickr

    But I can manually lock it. By pressing that button it remains locked

    [​IMG]Screenshot 2020-04-17 at 12.07.56 by Nigel G, on Flickr

    Thanks
     
  2. PeteRob

    PeteRob Well-Known Member

    I don’t understand PS, mainly because of the layers but it reads as if the current behaviour is exactly what you did before - either unlock the background to crop it or make a layer and crop that?
     
  3. dream_police

    dream_police Well-Known Member

    No it's not the same. The background remained locked unless I manually unlocked it. I could crop an image, it would crop but remain locked. Other things cannot be done on a locked layer, hence new layer would need creating. The default position on that layer (the first one that opens, the background) is locked unless the user unlocks it. That default has now changed where I now need to lock it. I have compared it to 2019 which I still have. That behaves as it should do. I only update PS when I choose. No update has affected 2020. The only person who has been using it other than me is my wife. My daughter has it on her laptop (2019 at present) and hers does as mine used to.

    All the preferences between the 2, 19 and 20 are the same, so can't see anything in there that needs changing.
     
  4. dream_police

    dream_police Well-Known Member

    I should make clear ( as I've only just noticed) the files when opened are by default partially locked, not fully locked. After cropping that image in CC 2019 it remains partially locked with the padlock showing. In CC 2020 after the crop the padlock goes and is now fully unlocked. That is what has changed in the past week and not due to an update.

    I have been running 2020 for months now, so this isn't just a feature of this version this has changed only recently (since my wife has had a play)

    My daughter is just updating to CC 2020 so will compare with her setup but the behaviour of mine has flummoxed her so far and she uses PS a lot at uni.
     
    Last edited: Apr 17, 2020
  5. dream_police

    dream_police Well-Known Member

    More photo's to may be explain

    So, background is showing the padlock. I then create a new copy layer.

    [​IMG]Screenshot 2020-04-17 at 13.24.59 by Nigel G, on Flickr

    I then want to crop on the background copy layer (that is the highlighted layer prior to selecting crop and it shows the crop preview)

    [​IMG]Screenshot 2020-04-17 at 13.25.24 by Nigel G, on Flickr

    Do the crop on that layer and the original background now changes its name to layer 0 and the padlock has gone until I lock it again. This is different to what it used to be.

    [​IMG]Screenshot 2020-04-17 at 13.25.40 by Nigel G, on Flickr
     
  6. dream_police

    dream_police Well-Known Member

    I have just compared it with my daughters 2020 version which is exactly the same version as mine. All preferences are the same. Hers does what mine used to do and should still be doing. I cannot see a difference between hers and mine in the settings. I will reset mine and see what happens.
     
  7. PeteRob

    PeteRob Well-Known Member

    Good luck! That's a very clean chain BTW. Can't get mine that shiny.
     
  8. dream_police

    dream_police Well-Known Member

    Reset it it all and now back to as it should be. Now I just need to discover what settings I have now lost by resetting!
     
  9. Geren

    Geren Well-Known Member

    I've tried replicating the problem here but can't. Also, if I open an image and go on to duplicate the background layer I don't get a crop preview in the layers panel. I can see the way it will affect the image in the workspace but no new named layer called crop preview (CC 2020). Anyway, I'm glad you've fixed it. I did try googling but it was one of those search queries that resulted in everything telling you how to unlock the background layer, not keep it locked!
     
  10. dream_police

    dream_police Well-Known Member

    That’s all I found in google too. Thanks for trying anyway.
     
  11. Bazarchie

    Bazarchie Well-Known Member

    I have PS on windows so it may be different. In the crop tool, has the DeleteCropped Pixels option been unchecked?
     
  12. dream_police

    dream_police Well-Known Member

    I have reset now. I only used the crop as an example. The same would happen after using another tool, so I doubt it would have been the cause.
     
  13. Bazarchie

    Bazarchie Well-Known Member

    If it happens again may be worth a try as I got the same results as you if I unchecked that option.

    Personally I still find PS illogical.
     
    dream_police likes this.
  14. dream_police

    dream_police Well-Known Member

    Ok will bear that in mind. I might even do it tomorrow to see if that happens. Cheers
     
  15. dream_police

    dream_police Well-Known Member

    Just did as you suggested. Looks you were right, Steve. Having compared PS on 2 different computers side by side, we missed that check box. Ahh well.
    Cheers
     
    EightBitTony and Catriona like this.
  16. Gezza

    Gezza Well-Known Member

    Not trying to teach anybody to suck eggs but if you want to work on a duplicate layer just press command + j or control + j..... it obviously lets you preserve the original
     

Share This Page