1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. REMINDER

    Any content, information, or advice found on social media platforms and the wider Internet, including forums such as AP, should NOT be acted upon unless checked against a reliable, authoritative source, and re-checked, particularly where personal health is at stake. Seek professional advice/confirmation before acting on such at all times.

Is this normal?

Discussion in 'Pentax Chat' started by Vormulac, Jan 23, 2008.

  1. Vormulac

    Vormulac Active Member

    Thanks sirmy, it sounds like it is normal and I shouldn't be too bothered.
     
  2. grognut

    grognut Member

    Hi,
    My K10D does the same but works fine.
    I phone Pentax Customer services and they said that it was the counter weight for the shake reduction and that it was normal.
    If you power it on it clunks a little bit less.
    I also note that it only clunks when rocking it about the lense axis.
    Vormulac: Is this the same for yours?

    I don't know if I believe Pentax but it seemed logical. In fact he asked if it did it with the power on as well so it's something they are aware of. Doesn't mean it's right though!

    Cheers.
     
  3. Vormulac

    Vormulac Active Member

    Hi Grognut,

    There are enough people reporting the same thing but that their cameras appear to function perfectly for me to believe that this is perfectly normal, I certainly can't say there appears to be anything wrong with the way my K10D is working. If it packs up it'll be something I mention when I send it back, but to be honest I'm not overly worried now.
     

Share This Page