1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HLD9 Instructions?

Discussion in 'Olympus Chat' started by RovingMike, May 28, 2021.

  1. RovingMike

    RovingMike Crucifixion's a doddle...

    I can't find anything that tells me how to make the battery in the grip take over from, or support the one in the camera. Yesterday I went out with the camera showing 45% battery, that's with the grip attached. Only about 50/60 shots in it flashed up empty and died. So I removed the grip and the battery in the camera then read 25%. I switched it with the one that had been in the grip and that said 95%. Anyone know what's going on?
     
  2. PeteRob

    PeteRob Well-Known Member

    Might not be relevant but the other day I rotated the batteries (1 in camera, 2 in grip) on my Fuji X-H1 and, when I put the grip back on, the battery level indicator only showed one battery (the camera battery) while the grip release still functioned. I cleaned the contacts with contact cleaner including checking that the spring-loaded contacts were all moving freely. When I reattached the grip all three battery level indicators were again functioning.
     
  3. RovingMike

    RovingMike Crucifixion's a doddle...

    Ah the Oly EM1 mk2 only seems to have one battery indicator.
     
  4. alfbranch

    alfbranch Well-Known Member

    Battery grip priority Mike I dont have a grip anymore but it is under menu J2 and battery settings.
    You need to set it to PBH priority.
     
  5. RovingMike

    RovingMike Crucifixion's a doddle...

    Thanks Alf, but that doesn't solve it. It claims that one automatically follows the other in whichever order you set, but they don't. When exhausted, it just flashes zero until you manually switch them.

    But this time, it flashed empty when there was 25% in the body and 95% in the grip.
     
  6. alfbranch

    alfbranch Well-Known Member

    Sounds like a fault my EM1 i always worked OK.
     
    RovingMike likes this.
  7. alfbranch

    alfbranch Well-Known Member

    Mike it does sound like a fault.

    I did occasionally have a fault with my hld7 where one of the pins would stick in and the dials and buttons would not function unsticking the pin would sort it.
     
  8. IvorETower

    IvorETower Little Buttercup

    Mike, have you resolved this issue yet?

    I have to say, looking at the prices for grips for the E-M1 mark I and mark II, I'm staggered. Even used priced for the grip for the mark II seem ridiculously high whereas for the mark I, a bit of shopping around reveals that they can be bought (used) for under £30 without too much effort
     
  9. alfbranch

    alfbranch Well-Known Member

    The HLD9 fits the mark II and III so it is current.
     
  10. RovingMike

    RovingMike Crucifixion's a doddle...

    Hi not really. Oly finally responded and just said what it should do....that it doesn't. They had no advice to offer other than send it for repair. The price is astronomical and I'm not sure what possessed me to buy it.
     

Share This Page