1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D800 enforces maximum aperture in rain

Discussion in 'Nikon Chat' started by ChrisNewman, Oct 3, 2021.

  1. ChrisNewman

    ChrisNewman Well-Known Member

    Walking this afternoon I got caught by a few showers despite the forecast suggesting rain was unlikely. As usual I had my D800 with its strap round my neck, and my Solmeta Pro2 GPS on the hot shoe. The final, heaviest shower came as I was walking down a track. I didn’t stop to put the camera in my backpack, partly because there wasn’t a convenient spot, but mainly because I wanted a photo of a sign at the bottom (that’s another story). The shower was such that, if I hadn’t already replaced my pullover with a waterproof, it would have got rather wet, but not soaked. My D800 is supposed to be weather-sealed, although the GPS makes no such claim. I got to the bottom of the track, photographed the sign, and put the camera bag on a huge log protecting an adjacent farm gate. But the rain stopped, and I noticed a bright rainbow beyond the gate. So I went to take some shots, but noticed that the aperture had switched to f/2.8, the maximum of my Nikkor 24-70mm VR lens (I’d set a different aperture for the sign photo a minute or so earlier). I tried to reduce the aperture (I was using Aperture priority), but with no response, so I took my photos anyway. I then tried switching to different menu banks and modes to see if I could change the aperture. Program had no effect. Manual should have switched aperture control from the Main to the Sub-command dial, but that wouldn’t change the aperture either. In Shutter priority, when I reduced the shutter speed (the Main command dial changed this without problem), the display blinked to warn of over-exposure, but didn’t reduce the aperture from f/2.8.

    I left the camera around my neck, and after walking for another five minutes or so (dry, but mainly in the shade), I found control of the aperture had been restored. In contrast, there were still raindrops sitting on the camera when I got home after about another hour walking in the dry.

    Fortunately, sharpness is pretty much irrelevant for photographing a rainbow, and I don’t much mind how the field and trees below are rendered, so I suppose my shots have only really suffered from increased vignetting.

    Has anyone any suggestions as to what was affected by the rain, bearing in mind that neither command dial would change the aperture, but the Main command dial worked properly changing shutter speed? The lens seems pretty well weather-sealed. (I think something similar happened on a previous wet walk a few years ago, but I didn’t investigate in detail.)


    Chris
     
  2. Zou

    Zou Well-Known Member

    Moisture between lens and body contacts?
     
  3. spinno

    spinno Well-Known Member

    Put the camera minus batteries in a box or bag of uncooked rice and place in your airing cupboard for a couple of days if possible.
    That should dry it out.
     
  4. ChrisNewman

    ChrisNewman Well-Known Member

    Thanks for the suggestion, but there’s a sound-looking rubber seal between the lens and the mounting flange, the contacts are set a few mm inside, and I think it most unlikely that enough water would have got in to reach the contacts, which would have been on the higher part of the joint the way I was carrying and using the camera (except when taking the shot of the sign in portrait orientation). I’ve just removed the lens, and there’s no sign of any water in that area.
     
  5. ChrisNewman

    ChrisNewman Well-Known Member

    Thanks for that suggestion, which I’ve seen before, and leaves me puzzling as to why rice is always suggested as the absorbing medium (personally, I’d use the many packs of silica gel I’ve accumulated from various product packets, although I haven’t been saving those in the lateral flow test kits). If I’d dropped the camera into water I’d do something like that, but there’s been no sign of any water in the camera. I accept a little probably got into the camera, lens, or perhaps the unsealed GPS device. (Could the GPS affect the aperture through the 10-pin connector? It also acts as a wireless remote, and occasionally, if I press the button to turn of the GPS while the camera is still on, it will trigger the shutter.) But whatever was affecting the aperture control ceased within about 5 minutes (perhaps dried by internal heat from electrical activity?), everything looks and seems dry now, and I’d be more concerned about dust from the rice causing problems, or the camera falling out of the airing cupboard when someone comes to remove clothes, than how fast any moisture that might still be inside is dried out - the recent chilly weather has triggered our thermostat, so the relative humidity indoors is down to about 60%.
     
  6. GeoffR

    GeoffR Well-Known Member

    I had a similar problem with a 70-200 f2.8 VR after a heavy shower, drying the lens out cured the problem, some lenses aren’t water resistant.
     
  7. ChrisNewman

    ChrisNewman Well-Known Member

    Thanks for that information Geoff. I assume your 70-200 f2.8 VR, like my 24-70, claims to be weather-sealed. Unfortunately if my system gets stuck on maximum aperture in the rain again, I don’t think I should try swapping lenses in those conditions to see if the lens is at the root of the problem. But perhaps I should try disconnecting the GPS just to make sure that isn’t the cause. And as soon as I get back in the dry and have wiped off the camera and lens, I’d better check whether it’s still stuck on maximum aperture, remove the lens and look carefully for water where it’s mounted, and if it was still stuck, mount a dry lens and see if things change.

    It’s comforting that no-one yet has suggested that permanent damage is likely, and I should ignore the system’s weather-sealing claims, and be extra-careful to always keep my kit out of even light rain.
     
  8. PeteRob

    PeteRob Well-Known Member

    Cameras default to max aperture for metering and focus and then stop down to the taking aperture for the exposure. These days this is electronically controlled. So something has interrupted the communication between lens and camera. If the lens has a rubber seal on the mount then I am a bit surprised that this has happened because lenses can take a fair wetting in my experience but I don't use Nikon.
     
  9. GeoffR

    GeoffR Well-Known Member

    Rob, Nikon use full aperture metering but only some of the lenses use electronic diaphragms*. The 24-70 AF-S 2.8 ED VR is one of those that does but the aperture is set using the sub command dial on the body. The selected value is then communicated to the lens, to close the diaphragm, at the time of exposure. Chris is saying that he was unable to select a lower value than f2.8 on the body. I have had this happen but I can't remember how I fixed it. However, water and electronics rarely go together well so drying everything out is inevitably the first step.

    *Other lenses stop the aperture down mechanically.
     
    ChrisNewman likes this.
  10. PeteRob

    PeteRob Well-Known Member

    Old ones certainly but anything recent will be all electronic - I use Canon EOS - so that is electronic control since 1987. Mechanical or electronic the default position will be wide open.
     
  11. GeoffR

    GeoffR Well-Known Member

    Pete, the point is that Chris couldn't alter the aperture the body was asking for. As far as I can remember nothing to do with the lens.

    Recent in Nikon's case is 2016 for electronic diaphragm control but, when a Nikon lens with mechanical diaphragm coupling is removed from the camera it defaults to minimum aperture, aperture setting on G series lenses, without an aperture ring, is achieved by driving the coupling lever towards the fully closed position. the body does all the work. I don't know what happens with an E lens as I don't own any of them.
     
  12. ChrisNewman

    ChrisNewman Well-Known Member

    As Geoff said, the lens I was using is a Nikon E type, with electronic diaphragm and no aperture control on the lens. It seems to default to maximum aperture with no input from the camera. I’ve had ongoing intermittent problems with the mount on my D800 losing communication with lenses, although it’s been OK since the 2nd repair in March last year; with loss of communication, a delta-type symbol which is supposed to indicate no lens is mounted, appears, and the camera won’t shoot.

    I’m puzzled as to what caused the problem of being locked into maximum aperture in the rain.

    The lens seal against the mounting flange looks sound, the contacts are set back a little way into the mount, there was no water visible when I belatedly removed the lens to look, the behaviour was different to what I’ve experience with loss of contact problems, and if water had got to the contacts, I wouldn’t have expected the problem to clear up within 5 minutes.

    My first thought was that water had got in by the main command dial, affecting it’s action, but switching modes showed that that dial was still able to work, while the sub command dial was unable to change the aperture.

    My Solmeta GPS unit doesn’t claim to be weather-sealed, and I have it set to log where I’m walking every 10 seconds, meaning it’s constantly using electricity and generating some warmth, so drying out could explain the rapid recovery. But I don’t know whether Nikon’s 10-pin connector system that links it to the camera can be used to change aperture, and if it can, whether my Solmeta has a wire to the relevant pin. The Solmeta certainly isn’t supposed to be able to change apertures. (The Solmeta also has what look like metal contacts on the side and base of the hot shoe, but they’re not necessary for it’s operation, so I suspect they’re just for mechanical stability.)

    Geoff reported a similar problem, which he attributes to his lens, despite his and my lenses being weather-sealed. I don’t know whether, if water did get into the lens, it could enforce maximum aperture, but, again, if that’s what happened, I’m surprised the water would have cleared from within my lens within 5 minutes.
     
  13. PeteRob

    PeteRob Well-Known Member

    There may be no aperture dial on the lens but I expect the construction is an internal motor operating against a spring with the number of motor turns required to stop down to a selected aperture preset and the default wide open. In which case "it is the lens" that stops down. The camera can't move the diaphragm, all it can do is tell the lens motor to move. The camera seems to be missing the lens information that says what its range of stops is. On a mirrorless you have to set something to tell the camera to operate without a lens attached if you want to use a mechanical lens via an adaptor else it won't work. As already worked out it seems that the communication between lens and camera has failed. It might be a coincidence that it was raining at the time this happened. Give the contacts a good clean.
     
  14. GeoffR

    GeoffR Well-Known Member

    Pete, on a Nikon if the lens loses contact with the camera the aperture display goes to either ∆F0 or, if one has been set, the value for the first non-CPU lens. If it was displaying F2.8 it must have had some contact with the lens or Chris has set f2.8 for a non-CPU lens. As I said, I have seen a similar situation where I have been unable to change the selected aperture but can't remember the fix.
     
  15. ChrisNewman

    ChrisNewman Well-Known Member

    I realize that with E-series lenses, the camera can only tell a motor in the lens to change the aperture, but thanks for the extra detail.

    That seems to me to be misunderstanding the situation; the camera had the information to show f/2.8, the maximum aperture of the lens; it has no problem showing f/1.4 if I mount my Sigma 50mm A and set maximum aperture.

    I’m certain it was no coincidence that it was raining at the time. I’ve experienced similar behaviour once before in the rain, and so has Geoff. Conversely, I’ve experienced the camera’s problem with failing communication with the lens hundreds of times (before the blissful freedom from that issue since March 2020), and it’s always shown the delta-type symbol indicating no lens is mounted, and refused to operate the shutter. So I’m sure the contacts are OK now; it is possible they got wet during the rain, but I very much doubt it.
     
  16. ChrisNewman

    ChrisNewman Well-Known Member

    I don’t have any non-CPU lenses, and so see the ∆F0 display, with the camera refusing to operate the shutter.
     
  17. GeoffR

    GeoffR Well-Known Member

    Which means the camera was detecting a lens and the maximum aperture.
     

Share This Page