1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Using the new Olympus EM1 with an adapter and Four Thirds lenses

Discussion in 'Olympus Chat' started by Queenfisher, Dec 12, 2013.

  1. Queenfisher

    Queenfisher Member

    Hi, is anyone able to give me a review on using the EM1 with Four Thirds lenses. I am thinking of upgrading but don't want to have to buy all new lenses, the camera is expensive enough! Specifically, is the auto focus still as super dooper fast as they say. Is there a loss of functionality if using the adapter? Any advice would be appreciated.

    Thanks
     
  2. RogerMac

    RogerMac Well-Known Member

    Re: Using the new Olympus EM1 with an adapter and Four Thirds le

    Afraid I have not tried my FT lenses on an M1 so I am not in a position to comment on the AF speed aspect. However I have used them on an early Pen via the MMF1 adaptor and there is no loss of functionality. As the MMF3 adaptor for the M1 camera is very similar to the MMF1 - just with the addition of weather seals at each end - I am sure that there will be no loss of functionality.

    Only half an answer to your question but it may help.
     
  3. Footloose

    Footloose Well-Known Member

    Re: Using the new Olympus EM1 with an adapter and Four Thirds le

    Based on owning the E-1 & E-3 for which I also have a number of 4/3rds lenses, but also have the OM-D and E-M1, I can say that whilst 4/3rds lenses would occasionally 'hunt' when the MMF-3 on the OM-D, I haven't encountered the same issue with the E-M1. I therefore have come to the conclusion that what 'hunting' I have experienced, is down to the the AF system in the body, not the MMF-3 adaptor. As you know, the E-M1, uses 2 different AF systems, and seems to seamlessly switch between these two. The E-M1's system is slightly faster than the OM-D's. So far I haven't uploaded the recently announced Firmware update, and haven't heard of any firmware updates released specifically for any of the 4/3rds lenses. I make that last qualification because I am not too sure if when a lens-related firmware update is released, this is held on the 'chip' within the optic, and not just within the body.
     
  4. Queenfisher

    Queenfisher Member

    Re: Using the new Olympus EM1 with an adapter and Four Thirds le

    Thank you. I think I shall take the plunge. I have also spoken with Olympus who were most helpful, I know, they want to make a sale! My main dread now is having to sit down and learn a whole new menu which I'm assuming is totally different to the E series. Thanks again for your comments.
     
  5. Zou

    Zou Well-Known Member

  6. UKSteve

    UKSteve New Member

    Resurrecting this useful old thread.
    I just tried my Olympus 4/3 lens, with my Olympus adapter on my EM1 Mark i, and nothing! This used to work fine, but now I have no connectivity for control of focus or anything.
    Does anyone know if Olympus have done something to the firmware to stop EM1 Mark i users, using the old 4/3 lenses via the adapter they sell?
     
  7. UKSteve

    UKSteve New Member

    Panic over - cleaned the contacts, as not used this lens for a while and all working perfectly again
     
    RogerMac and Andrew Flannigan like this.

Share This Page