1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pentax Digital Utility 5 - very slow

Discussion in 'Pentax Chat' started by cgproudfoot, Oct 15, 2014.

  1. cgproudfoot

    cgproudfoot Well-Known Member

    I upgraded from 4 to 5 with the K3, and find the new software very slow. I am using a Corei5 with 8GB RAM, so plenty of power!

    Any ideas?
     
  2. Atavar

    Atavar Well-Known Member

    Mmm, no idea, sorry. Sometimes driver updates can save the day but other than that I'm stumped.
     
  3. Done_rundleCams

    Done_rundleCams AP Forum Ambassador to Canada


    There was some sort of update for Pentax Utility 5. Maybe that might be the reason … scroll down to the second section of updates :)

    http://www.ricoh-imaging.co.jp/english/support/download_digital.html

    Cheers

    Jack
     
  4. Ffolrord

    Ffolrord Well-Known Member

    The Pentax Utility software supplied with the camera has always been hopelessly slow. I don't know anyone who actually uses it.
     
  5. cgproudfoot

    cgproudfoot Well-Known Member

    I followed Jack's advice, upgraded, and everything fine now!

    Thanks, Jack
     
  6. Monobod

    Monobod Phantom of the forum

    That's another pint you are owed Jack! ;)
     
  7. Done_rundleCams

    Done_rundleCams AP Forum Ambassador to Canada

    Wow … really :eek: and glad to of help, Craig :)

    Cheers,

    Jack
     
  8. Done_rundleCams

    Done_rundleCams AP Forum Ambassador to Canada

    I knew I stopped drinking beer to soon, David ;)

    Cheers,

    Jack
     

Share This Page