1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OM-10 'Wind Lever Not Working'

Discussion in 'Olympus Chat' started by PeteE, Sep 11, 2017.

  1. PeteE

    PeteE Well-Known Member

    I tried out an OLYMPUS OM-10 which was given to me by a Camera Club member as 'Winder Jammed' -- well, I put I 2 new batteries, set it to 'Auto' exposure as he had it set to 'Manual Adaptor', set to 'Check' and suddenly it all worked, so I 'lubed' the cogs and levers in the base-plate with Sewing Machine Oil . I found a Febraury 2000 dated Fuji Superia 800 and loaded it and rated it at 200 ASA and processed a short length in my C41 mix and got evenly exposed negatives -- very 'grainy' but Camera now works and winds on 'Sweetly' !!
    Lady and her Dog caught holding Camera at waist level, f4, 28mm lens
    [​IMG]OM-10 Test 02 by Peter Elgar, on Flickr
     
  2. beatnik69

    beatnik69 Well-Known Member

    I have an OM-10 that belonged to my grandfather (and the manual adaptor). I'm not sure if it works ( I think there is a prat turning round that shouldn't) but I might stick a couple of batteries in to see.
     
  3. Benchista

    Benchista Which Tyler

    I'm intrigued.... ;)
     
  4. beatnik69

    beatnik69 Well-Known Member

    Problem solved! :D
     
  5. PeteE

    PeteE Well-Known Member

    Ha Ha !! I think he meant 'PART' ------
     

Share This Page