1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nikon D7100 shutter/mirror problem

Discussion in 'Nikon Chat' started by Zak52, Jul 8, 2019.

  1. Zak52

    Zak52 Well-Known Member

    Ok, I sold my well cared for D7100 on the auction site, sent well applied via RMSD. Camera has around 10,500 shutter count. The buyer has come back with a problem .He states that around 50% of all the shots taken are completely black, and also when moved onto his PC. He has tried a different lens but problem is persisting although there seems to be no pattern to it, He goes on to say he shot a couple of hundred images this afternoon using both lenses and that probably 150 are fine, but 50 or so are totally black. The black pictures seem to occur in bunches then the camera will be fine again for a while before another bunch of pictures come out black. Sounds to me like a mirror/shutter problem. Maybe Royal Mail has been playing basket ball with it........

    I'll give it a good look over when I get it back. Anyone know of any recommended repairers before I give Nikon 300 quid?
  2. GeoffR

    GeoffR Well-Known Member

    Did you set up a non-CPU lens? If so it could be that the camera/lens interface is the problem, a dirty contact. If the camera loses contact with the lens it will revert to the non-CPU lens data and expose accordingly.
  3. Zak52

    Zak52 Well-Known Member

    Well I didn't but will investigate on its return. The guy said the packaging was bit battered which it certainly wasn't when it was despatched so Ive asked for pictures of the box.
  4. nimbus

    nimbus Well-Known Member

    Like yourself my initial thought would be a sticky mirror, it's where I would look first as presumably the camera has made the appropriate noises. I did once buy a used Nikon body which only had a shutter count of a few hundred that was suffering in this way.
  5. Zak52

    Zak52 Well-Known Member

    I'll see what happens when I get it back. I'll bang a lens on, insert a memory card select ÇH' and fire away :)
  6. IvorETower

    IvorETower Little Buttercup

    Any update yet ?
  7. Zak52

    Zak52 Well-Known Member

    Well, the day after my last post the guy came back to me and said it was working fine so he was happy to keep it. Then a few days later the problem resurfaced so I agreed to have it back. It arrived yesterday so I tried it out this morning with my Sigma 10-20mm and it wouldn't focus or fire at all in any mode. I tried it with 2 other lenses, my 18-200 vr and my 35 1.8G and it seemed fine. I set the shutter mode to 'continuous high speed' and fired it off a few seconds. It's working now with all lenses, including the Sigma so I'll use it as my main camera for a few days to see if I can fathom out what's going on. I'll send it off for a service if the problem persists.

Share This Page