1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Firmware update

Discussion in 'Help Team' started by D5000c1, Apr 18, 2017.

  1. D5000c1

    D5000c1 New Member

    Hi people

    I have tried updating firmware on my camera but I am struggling big time

    I've been on the Nikon website and gone through all of the process but having no luck

    So this is what I've done

    I went on Nikon site and found my camera D5000 then clicked on it and pressed to download it
    Then once downloaded I put the firmware onto my sd card and then put into my slr
    And clicked on firmware update

    But it didn't show up on my camera the new update

    I've tried several times but don't know what's going wrong

    Thanks
    Charlie
     

    Attached Files:

  2. peterba

    peterba Well-Known Member

    The first thing that occurs is: check that your Operating System hasn't added a [1] to the end of the filename (or another number in square brackets). Operating Systems will often do this if you have a previously-downloaded file (or files) of the same name in the folder.

    If that's not it, then I don't know, since I'm not a Nikon user, but I'm sure that others on here will be able to help.
     
  3. spinno

    spinno Well-Known Member

    If it is like Pentax then you have to load a bin file to the root memory of the card. Other than that I'm clueless.
     
  4. PeteRob

    PeteRob Well-Known Member

    Follow the directions in the manual precisely - they probably start (and end) with formatting the card.
     
  5. El_Sid

    El_Sid Well-Known Member

    Have you checked the firmware numbers currently installed in your camera - if it already reads V1.01 for A and 1.00 for B then there is nothing to update as this was appears to have been the only update issued...
     
  6. IvorCamera

    IvorCamera Well-Known Member

    I had big problems too when I first done this 3 or 4 years ago, so I popped a formated card and downloaded everything it said from the nikon website, and after a few attemps it worked, so keep trying.....your camera may already have the latest firmware on it so check that first....if you still cant do it dont worry some camera firmwares will make no difference to your results...
     

Share This Page