1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Blinking BCM-2

Discussion in 'Olympus Chat' started by t2o, May 6, 2009.

  1. t2o

    t2o Member

    I have 2 batteries for by E-330 - the Oly original and an Ebay cheapo. I've had them both for a couple of years. My BCM-2 charger LED now blinks red while it is charging the cheapo battery and is taking a very long time to do the job, if it ever finishes.

    Has anyone ever had this problem? and is there a solution?

    John
     
  2. Benchista

    Benchista Which Tyler

    Batteries are consumables, and it looks like your battery has reached the end of its life. Solution? Chuck it out and buy a new one, I'm afraid.
     
  3. t2o

    t2o Member

    Thanks for that. I'm a bit surprised at the short life - I don't take a huge number of photographs, say 1000 on holiday each year plus 2-300 more during the year so that would be 2-3000 since I got the camera in 2007. I've been using a set of rechargeable AA's in my c3040 since 2002 that are still going strong, admittedly on a lower snap rate.

    Well, the cheapo was cheap enough, I think it was 2 for a tenner from the USA. Thanks again.

    John
     
  4. Manofolympus

    Manofolympus Well-Known Member

    Sadly one of the things you trade off with cheap rechargeables is a long useful life. Also, the important thing is the number of charge/discharge cycles rather than how much the battery is used-hence if it goes flat on storage and you recharge it that shortens the lifespan the same as if you take 200 pictures and recharge it
     
  5. Bone_Idle

    Bone_Idle Well-Known Member

    If you want a decent third party battery then look at the Uniross version. I've had one for years and it's still going strong.

    Uniross VB104295
     

Share This Page