1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

a7mkii camera error

Discussion in 'Sony Chat' started by StevieS, May 2, 2017.

  1. StevieS

    StevieS New Member

    I have had my a7mkii for 18 months. It is my back up camera and has hardly been used. It has never been knocked,dropped or been in contact with water or humidity.
    On a couple of occasions since purchase the camera on start up has come up with the message camera error switch off and restart. This has worked but now I get the message every time. Switching off does enable the camera but this can happen if I just press menu or any other button. Sony say it is not a known fault though the internet is stacked with similar stories. Any advice much appreciated.
     
  2. Steve52

    Steve52 Well-Known Member

    Despite what Sony says, I'd send it back to them. Is it still under guarantee? It obviously is a fault. At best, they'll give it a full service and clean and then, if the problem re-surfaces, you'll have some back-up.
    You could also try asking Gary Friedman (google Friedman archives), he's an expert on Sony (IMO knows more about Sony cameras than Sony do) and see if he has anything to offer.
    Good luck.
     
  3. StevieS

    StevieS New Member

    My first ever post and I get some good help. Many thanks Steve 52
     
  4. frank1

    frank1 Well-Known Member

    Does it have a reset function in the menu. I have an A7 and have had no problems with that "touch wood". I have an A77 bought secondhand that had an issue and used the reset function on that and it solved the problem.
     

Share This Page