Results 1 to 6 of 6

Thread: OM2n

  1. #1
    Join Date
    Apr 2012
    Location
    Leicestershire
    Posts
    2

    OM2n

    I have an Olympus OM2n and my Tamron adaptor is stuck on the camera! The adaptor will turn but I cant get it off! Does anyone have any ideas please?

    Thanks

    Liz

  2. #2
    Join Date
    Apr 2010
    Location
    South and east of where I was but going west
    Posts
    6,335

    Re: OM2n

    What has happened to the lens lock release button? Is it still there?

    On the Tamron mount in my hand at the moment, it is on the back half of the adaptor which is in two parts joined by four cross head screws. So - even if the four screws holding the AD mount together have all sheared (most unlikely) - you should still be able to push the lens lock button in and - while holding it and the serrated part of the ring - rotate and withdraw the remains of the AD mount from the lens throat.

    Any chance that you could post a digi pic to show the mount and camera body?

  3. #3
    Join Date
    Apr 2012
    Location
    Leicestershire
    Posts
    2

    Re: OM2n

    Thanks for your reply

    The adaptor is turning when I press the lock button but it won't come away from the camera it feels stuck.

    I will post a picture this evening when I get home from work.


  4. #4
    Join Date
    Apr 2010
    Location
    South and east of where I was but going west
    Posts
    6,335

    Re: OM2n

    There is another small slot screw at 90 degrees to the lens centre line and about 120 degrees around the circumferance of the mount from the lens lock button travelling clockwise. It is close to the bottom one of the three bayonet flanges. I suppose it is just possible it has come loose and is fouling the lens mount in some way.

    I suggest holding the camera in different orientations (upside down, etc.) while holding in the lens lock button and rotating the Adaptall mount clock<>anti-clockwise, backwards and forwards. Shaking the camera while you do so may also help. Then try pulling the mount off the camera again.

    I have, on a couple of occasions, grabbed a Tamron lens and the lens lock button/lens mount in a clumsy way when changing lenses and removed the lens but not the adaptor from my OMs. In that event I have not encountered any trouble in removing the mount and reconnecting it to the lens, so this one is a bit of a puzzle.

  5. #5
    Join Date
    Jul 2007
    Location
    Really Here In Name Only
    Posts
    11,712

    Re: OM2n

    I have, on a couple of occasions, grabbed a Tamron lens and the lens lock button/lens mount in a clumsy way when changing lenses and removed the lens but not the adaptor from my OMs. In that event I have not encountered any trouble in removing the mount and reconnecting it to the lens, so this one is a bit of a puzzle.
    Yes, me too. I have a suspicion the OP's problem is one I could sort "hands on" in five seconds flat but simply can't be done over the net, unless one of the suggestions above has worked.
    If you're not living on the edge, you're wasting space

  6. #6
    Join Date
    Apr 2010
    Location
    South and east of where I was but going west
    Posts
    6,335

    Re: OM2n

    Any news, Lizzie, on the Tamron mount problem?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •